Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Bug in GR-1 that makes it unusable for me. Please help!

So i bought a used GR-1 and have had it a few weeks now. I started by just kind of learning with the unit itself and creating my own patches etc. I now have some great patches and have hooked up the GR-1 to my MPC-X to sequence. A lot of my sounds are pad sounds with the decent release set to it. I have found that as soon as I hit play on the MPC the GR-1 resets the release value to zero. This will also happen when I trigger notes on the pad. I have done a lot of testing and found that a reboot of the GR-1 will fix this. It will work with the MPC-X without the issue as long as I don't hit start. As soon as that happens the GR-1 will keep resetting its release value over and over until I reboot. I need to be able to sequence this thing and this bug has made me really regret buying it. Any suggestions?? Thank you.

Comments

  • We've examined the MPC-X with the GR-1 in the lab found the two cooperate perfectly. We suspect there may be some MIDI CC's configured on the MPC-X that confuse the GR-1. Please try to check which CC's your MPC is sending and check the CC list in https://www.tastychips.nl/downloads/User-manual-GR-1-v1.6.pdf .. MIDI Control table chapter.. There's probably a way to turn it off.
  • edited February 4
    I will double check this. I can turn off the MPC-X which wipes everything and the GR-1. As soon as play is pushed it will cause the bug. After I do that and move the release slider again it will randomly play the release and not release as I hit the pads. I would be more than happy to make a video. Other than that yes the GR-1 and MPCX are nice together. If you have a mpc available it may also be worth another test.

    edit : I wont be home until later but just got the idea to turn off midi sync on that dedicated midi out port for the gr-1 and let you know what happens.
  • Unfortunately we do not have our own MPC-X.. A customer once brought one over and so we tested it for a day.

    The GR-1 has Release parameter on CC 26. I'd check if the MPC-X sends that...
  • So nothing I tried has worked, even turning midi clock off on that port didn't help. you can see after I hit play that release doesn't work even after I change it again on the GR-1. As far as midi cc, I thought transport control was a sysex message? I made you a video,

  • Transport control can also be done with CC's.. Arturia's sequencers use this, for instance. Without knowing what your MPC sends we cannot reproduce the issue here. The MPC-X is a very complete workstation and can be configured in a lot of ways, which may cause it to send CC's.. We recommend you hooking up the MPC to your PC/Mac and using a MIDI monitor to get a MIDI dump. Can you send us this file?
  • It could even be program changes or something.. Which will effectively reset the current patch back to default.. In any case, please make that MIDI text dump and send it to info@tastychips.nl or copypaste it here. On Mac, MIDI Monitor is a good tool. On Windows MidiOx..
  • I will get the dump as soon as I can. It might be Wednesday but will try for today. I also have a friend coming Thursday with a mpc live and a octatrack for testing purposes....thanks.
  • so hitting play displays nothing, but hitting the stop button I got this

    TIMESTAMP IN PORT STATUS DATA1 DATA2 CHAN NOTE EVENT
    0000A79D 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A79E 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A79F 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7A0 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7A1 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7A2 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7A3 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7A4 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7A5 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7A6 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7A7 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7A8 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7A9 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7AA 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7AC 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
    0000A7AD 1 -- B0 40 00 1 --- CC: Pedal (Sustain)
  • Thanks. Will analyze this in the coming days..
  • You already filtered out the Note on/off's? It should really provide a wealth of data..
  • I didn't filter anything out, I just hooked it up and then hit play and then stop. It seems like hitting just play doesn't cause the issue but I will test more. It seems to be hitting the stop button causes the issue. hitting play registered nothing and hitting stop generated the cc pedal sustain. I can hit notes and stuff at first or make a sequence if you want more data.
  • Ok, will try to throw in some sustain off CC's mixed with note on/off's and see how that goes.
  • I did a lot more experimentingnd the issue is with me double tapping stop. I am positive this is what causes the issue..here is the cc data from that event.

    00009590 1 -- B0 7B 00 1 --- CC: All Notes Off
    00009591 1 -- B1 7B 00 2 --- CC: All Notes Off
    00009592 1 -- B2 7B 00 3 --- CC: All Notes Off
    00009594 1 -- B3 7B 00 4 --- CC: All Notes Off
    00009594 1 -- B4 7B 00 5 --- CC: All Notes Off
    00009596 1 -- B5 7B 00 6 --- CC: All Notes Off
    00009597 1 -- B6 7B 00 7 --- CC: All Notes Off
    00009598 1 -- B7 7B 00 8 --- CC: All Notes Off
    00009599 1 -- B8 7B 00 9 --- CC: All Notes Off
    0000959A 1 -- B9 7B 00 10 --- CC: All Notes Off
    0000959B 1 -- BA 7B 00 11 --- CC: All Notes Off
    0000959C 1 -- BB 7B 00 12 --- CC: All Notes Off
    0000959D 1 -- BC 7B 00 13 --- CC: All Notes Off
    0000959E 1 -- BD 7B 00 14 --- CC: All Notes Off
    0000959F 1 -- BE 7B 00 15 --- CC: All Notes Off
    000095A0 1 -- BF 7B 00 16 --- CC: All Notes Off
    000095A1 1 -- B0 78 00 1 --- CC: All Sound Off
    000095A2 1 -- B1 78 00 2 --- CC: All Sound Off
    000095A4 1 -- B2 78 00 3 --- CC: All Sound Off
    000095A4 1 -- B3 78 00 4 --- CC: All Sound Off
    000095A6 1 -- B4 78 00 5 --- CC: All Sound Off
    000095A7 1 -- B5 78 00 6 --- CC: All Sound Off
    000095A8 1 -- B6 78 00 7 --- CC: All Sound Off
    000095A9 1 -- B7 78 00 8 --- CC: All Sound Off
    000095AA 1 -- B8 78 00 9 --- CC: All Sound Off
    000095AB 1 -- B9 78 00 10 --- CC: All Sound Off
    000095AC 1 -- BA 78 00 11 --- CC: All Sound Off
    000095AD 1 -- BB 78 00 12 --- CC: All Sound Off
    000095AE 1 -- BC 78 00 13 --- CC: All Sound Off
    000095AF 1 -- BD 78 00 14 --- CC: All Sound Off
    000095B0 1 -- BE 78 00 15 --- CC: All Sound Off
    000095B1 1 -- BF 78 00 16 --- CC: All Sound Off

  • Noted. Double tapping stop indeed often triggers stopping of all notes and also muting/fading the sound. On the Arturia controllers it's a triple tap, for instance. But this does not explain why the release parameter is set to 0.. I think what may happen is the GR-1 resets to preset values. The solution would then be to save the settings using:
    1) Press Perf
    2) Press Shift+Save to quicksave the current preset and the performance settings.
    .. and try again?
  • I have saved the perf in this manner. This is how I choose to save with the machine. A reboot also brings the perf back to where it was saved. The double tap of stop will still freak the GR-1 out and it will not do release correctly until rebooted.
  • edited February 11
    Peculiar. The All sound off MIDI command will soft mute the envelopes. Which means the release gets set to 0.. _until_ a new note is played.. There must be some kind of bug in here that doesn't respect the new note or so.. Will keep you updated.

    Just out of curiosity, why is the double-tap stop used in this case?
  • I have just got use to using the double stop. I am trying to change my way of thinking until we have a fix. The main reason I like to double stop is that it will kill any drum loops or other samples right away when I want to stop the pattern.
  • Ok, clear.

    I just fixed the issue. The 2.0 firmware should include this fix. But it will take a week or two before properly tested. Stay tuned!
  • awsome, thanks so much Tasty Chips!
Sign In or Register to comment.