Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Stuck on "Press select to upgrade "

Hi there, I'm trying to update to the latest firmware, but I can't get past the Press select to upgrade screen. Pressing the select encoder doesn't seem to do anything. The encoder functions normally during usage of the Gr-1, any ideas of what the issue could be? Thanks!

Comments

  • Does it hang in this screen? Or does it proceed onto the main screen?
  • It just hangs there. I left it for about 20 minutes and powered down. Tried again and same thing. I tried a different USB key and external usb drive, and neither of those even registered the firmware update was present, and none of the other wav files on either drive were accessible.
  • edited April 28
    Ok, understood. Have you read the troubleshooting section in the manual to the letter? It has many tips on how to avoid such issues. https://www.tastychips.nl/downloads/User-manual-GR-1-v2.0.2.pdf
  • I have indeed. I reformatted 2 USB drives just to make sure, and still no luck with the update loading. I'm really unsure what I'm doing wrong.
  • Have you tried multiple browsers?
  • OK it worked! I bought two new USB keys and one of them did the update! The Lexar brand seemed to be the one that did it. Do you guys have any recommendations for USB keys that you feel like work best/fastest with the GR-1?
  • Good to hear. We use Sandisk Ultra's mostly. Will keep Lexar in mind. Thanks. Sticks that you should avoid are the unbranded ones, some are 4 times as slow as others..
Sign In or Register to comment.