Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

ECR-1 Freezlike behaviour

Hej,

I'm in the process of learning my ECR-1, but I encounter an issue that keeps returning.

When I power my eurorack, all is working as it should, but after some time the module seems to get into a strange state.
The C symbol is displayed on the screen constantly and if I dial any knob, it seems to be previewing the convolution.
If I then turn off the power of my eurorack and turn it back on, all is back to normal.
Is there any advise you could give me on this, because besides it being rather annoying, it also is quite loud!

I created 2 movies and have it in dropbox, hoping that it explains the problem better. You can get them via:

This one was when I had the problem:
https://www.dropbox.com/s/5iqhgzfa5yh2jbi/20200430_151137.mp4?dl=0

And this one directly after reboot:
https://www.dropbox.com/s/en2j18xwxv5i7jq/20200430_151241.mp4?dl=0

Thx.

Nik Mettez
«13

Comments

  • Hhmm, thanks for the heads up, and the detailed videos!

    It indeed seems to be in a preview like state, but the play LED isn't burning, is it? I think we managed to reproduce something similar a while ago.. Then tried feverishly to reproduce it but to no avail. I would guess it's a software problem. The good news is that we can just snailmail you a new CM3 to fix the problem once we've reproduced it.

    Question: any idea what triggers it? Any action or input signal??
  • What is your serial nr.. and did you perhaps turn "Slew" all the way down? (although this does sound different than a very short slew..)
  • Hej,

    Thanks for the uuuultra quick reply!

    I can confirm that the play led was not burning.

    What triggers it is still unclear to me. Pretty sure it's not action related, because today it happend without me turning any dials.
    I dialed in a setting and left it.
    The input signal I used was an audio sample that came from a1010music Bitbox, but it has also happened with other modules.

    Something that I was thinking was that it maybe starts when using long impulse responses that in conjunction to some settings overload the memory causing it to freeze? But this is only a bold assumption, that is neither based on technical knowledge nor skill. :)

    What I can do to help, is try to document as much as possible when it occurs again.
    What impulse response is used, what is dialed in, what i am using as input signal...
    If you want me to document anything else when it happens, i'm open to suggestions.

    Thanks.

    Nik Mettez




  • Thank you for all the detailed information.

    The red C indicates clipping (or actually saturation) of the wet input. So, I'd suspect it has something to do with input processing.

    If you could indeed supply us with settings like which response (perhaps sending us the wav?) and what type of input signal, that would be really valuable. Once we can reproduce the bughunt is that much easier.

    Cheers!
  • Any update? (sorry to nag ;))
  • Hej,

    Does not feel like nagging al all. It's nice to see this level of support - in the timeframe it is given. Thank you for that.

    So, I was playing around with the module from 10isch today, and at 12:30 it freezed again.

    I was experimenting with a couple of impulse responses that i gathered on the interwebs, but before putting them on the usb drive, i removed all the others. This to make sure there was no faulty files causing any issues.

    What i noticed after turning the module on (at that point I had not yet turned it on), is that a couple of stock impulses were still on the module, that were not on the usb drive. To be more precise:
    - Falkland Tennis
    - Bottle Dungeon
    - Hamilton Mausoleum
    - York Minster
    - Middle Tunnel
    - R1 Omni
    - Terry's Warehouse
    - Lady Chapel A
    All are 48khz.

    Not sure if this is related, but i am trying to be as detailed as possible.

    While playing around, at one point i noticed, the audio dropped out completely for a very short period (less than a second). I checked if it was the Dry or Wet which dropped out, and I believe it was both. Not entirely sure on this, because it only happend 3 to 5 times.

    Moments later (less than 3 minutes) i noticed the module froze on me. On big difference from yesterday here was that it was frozen without the C on screen. The C later appeared while I was checking if the module was frozen or not.
    The only way to do this is by turning Position, Attack, Decay or select. The other functions didn't have this problem today, opposed to yesterday.
    After turning a few dials the C appeared on screen.

    This is the dry audio that i was feeding it (this is a parallel recording, because I split it out to process somewhere else, so it didn't go through the module): https://www.dropbox.com/s/q3hczo7b4l6x7ta/tasty chips freeze.wav?dl=0

    The settings of the module:
    Stereo width: Center position
    Pitch: 0
    X fade: Fully clockwise
    Slew: 1
    pre delay: Fully counter clockwise
    Hpf: 0
    Dry: Fully clockwise
    Wet Fully clockwise
    Pos: 0.251
    Attack: Fully counter clockwise
    Release: 1.0225
    Input Level: Fully counter clockwise

    this was the impulse response it was on:
    https://www.dropbox.com/s/02pvog3za7vtjaf/Studio Nord Foil 3sec flat.wav?dl=0

    There also was one in the background, but I don't have any details on that one, i'm afraid.

    Hope this helps.

    If i can do anything else to help, feel free to ask. ;)

    Thanks.

    Nik
  • Btw, the serial number is 01 Rev 04-20.
    Only saw that you requested this now. :)
  • Thanks for the super detailed report.

    The responses on the module itself are normal. You can read more about them (all from openairlib.net) in the manual: https://www.tastychips.nl/wordpress/wp-content/uploads/2020/03/quickstart.pdf

    The 2-3 hours period before the event occurs is of course quite tricky for us to reproduce. Is there anything you did to get into this semi-freeze mode a bit faster?

    Dropouts can occur when switching between responses a lot. Especially long ones. We tried to eliminate them completely, but they seem very sporadic in normal use. Enough to make a proper recording in one take.. They do seem unrelated to this issue, because the one time I experienced this I wasn't using the controls at all. Same for you?

    Thanks for the audio and the response (will test). Did you input Doepfer level audio?

  • Hej,

    There wasn't anything specific i did tot get it to freeze. Same as yesterday, i was experimenting with settings on same basic patch i created
    .
    Hard to tell for me if it was related to controls, but i don't think so.

    As far as input goes, it was indeed doepfer level audio.

    kind regards.

    Nik
  • Hi Nik,

    Now running long tests with your convolution. So far everything still seems ok. If we don't manage to reproduce I've already got an idea for a quick reset feature (hold down all buttons for 3 sec). I hope that would help as a workaround.

    Cheers!
  • Hej,

    That might work, but I would give it some time before implementing it.
    More and more modules are being sold/received (i think) so i suspect that time can give an insight on the scope of the issue. Maybe someone smarter than me even comes up with a reproducable procedure. :)

    Thanks again for the effort.

    Nik



  • i get the red c constantly but my unit doesn't freeze
  • please insert the reset command in the manual
  • edited May 6
    The red C is the wet clip indicator. It's in the manual. But it's not a very serious thing, as the ECR almost always handles wet clipping by automatically reducing gain ahead of time. A convolution blowing up is a quite normal thing, and that's why we included this feature. The C only indicates automatic gain reduction has kicked in. Furthermore, you can get input signal clipping, but that mostly happens well beyond these levels. Mostly with Doepfer levels and moving the input level pot clockwise.

    At this moment we still can't reproduce Nik's problem over here even with the supplied response.
  • I'll be patching again this weekend.
    Something I plan to do is document the hours I spent patching, and the times the issue occurred, and try to keep an eye out for what might be the cause.

  • Ok, thanks man. Yesterday I ran your response with Doepfer level continuous signal from the A-110 VCO.. I couldn't reproduce it. Sometimes it _seems_ like it's doing it, but it's only when the position is at 0.. Then it typically should "clap" when slew is low.
  • ..continuing the test today. So far, everything seems fine. Same test conditions as yesterday. Run time now 3 hours.
  • after 9 hours still ok. but didn't apply continuous envelope modulation. will try that tomorrow. maybe that will get it stressed.
  • Hej,

    Didn't get round to patching much this weekend, but i powered on the modular yesterday, and today the entire day just to see if the freeze would happen without much wiggling.

    I'm glad to report that this was not the case. Seems like in static operation the problem doesn't occur.

    Hope to find some time to do some patching the next couple of days, and will keep you posted on the findings.

    Thx.

    Nik
  • Static operation means no fingers or does it also mean no modulation? Today I'll setup a test again. Thanks once again for all the research work. :)
  • No problem, a good way to learn the ins and outs of a new module. I should do this more often, as i have a number of modules where i didn't go that in this deep. :)

    Static is indeed without modulation, not with cv, nor physically. All I did was after a couple of hours turn a few dials to check if all was good.

    One thing to note was that i had audio running through the module for the entire time.


  • Ok, I'll continuously modulate Pos and check back in a few hours. Hopefully that brings it into this state. Then I'll try again in debug mode and see if that gives any hint.
  • I've now modulated Pos continuously for the last 4 hours. And changed the responses from time to time, unplugged Pos CV a couple of times and wiggled those knobs. Still no cigar.

    Hhhhmm.. I'm thinking there may be something with your unit's hardware.. Or maybe the your power supply can't handle it? The ECR is quite demanding on the +12V rail when continuously recomputing.. Let me know..
  • Ok, after 8 hours I decided to also push the encoder.. Then, finally I could reproduce something that sounds close to what you have. I suspect it's the same problem. Now we still have to reproduce it in a shorter time than 8 hours (lol) and try to see what diagnostic tools will be useful here. It could be a good while before we have a solution. In any case, thanks for the detailed report and will keep you up to date.
  • Thank you for not giving up! :)

    Power should be fine i think, because it is in my smaller case, which is only filled up halfway.
    That said, the 1010 bitbox i have in there is also pretty power hungry.
    I created a new rack on modulargrid so you can have a look at the specs of what is currently in there (minus the ECR1):
    https://www.modulargrid.net/e/racks/view/1207824

    This is the power supply I used for my case:
    http://www.doepfer.de/A100_DIY_1.htm

    I noticed the module is not on modulargrid yet. Might not be a bad idea to create a page for it, as I know many modular peeps like to plan their racks on there, because it is a (semi) reliable source for all technical info and to get overviews of directions to evolve your rack into.

    The pressing of the select encoder might be something that could be worth investigating. When i had the issue the first couple of times, i was unsure what the button press actually did (why read manuals when you can play :) ), so i thought i was getting the module in some kind of mode which was causing this. If i think back, it did somehow seem/feel related to the issue occurring.

    Something else i noticed, but which could be a coincidence, is that after i backup most of the IR's from the usb drive, and loaded it with a limited set of my own, is that it seems to be occurring less frequent. So i would test with a usb drive that has factory ir's on it.
    Like i said, could be a coincidence but i prefer to give more info than not enough.

    Again, thank you for your effort and time, it is appreciated a lot.

  • Interesting.. It could be that the directory listing or loading somehow causes these claps.
  • It's on Modulargrid (3x last I noticed) but listed under Other/Unknown and a touch hard to find. :)
  • The past 2 evenings, i have been playing around with the module, and it didn't freeze on me. Yesterday for testing purposes i reloaded the usb drive with the factory IR's, to see is that could be the causing the issue.
    Strange. Because when i started this thread, i happened every 1-2 hours.

    Will probably be having a longer patching session over the weekend, so i'll keep you informed.
  • edited May 13
    @nikmettez Thanks for the update. The problem seems evasive ;) I have now tried a couple of times with convolver swaps.. but nothing. This is like looking for a needle in a haystack. What we need is a magnet. I'm now pulling apart the code into bitesized chunks to look at the problem from an angle where I may find out more. Any more information you may have is useful, but I don't want to pressure you.
  • Hej,

    I have been patching yesterday and today, and did not have any freezes. Superweird.
    The needle seems to have run off. :)

    Seems that after unloading the usb's factory IR's the problem has gone away? Could this be a thing even?

    So i'm afraid that at this point in time i cannot give you any more useful info.
    I'll keep my eyes open, and report back when it happens again.

    Nik.
Sign In or Register to comment.